Ramschkasten.de

Alles was so hängen bleibt

Excel Text rückwärts schreiben

Aus Gründen möchte man auch mal in Excel viel Text der sich in Zellen befindet rückwärts schreiben. Nun könnte man meinen da gibt es bestimmt eine tolle Formel bei Excel, so was wie REVERSE(Text) – macht es aber nicht. Bedeutet für den gemeinen Excel-Arbeiter; dann muss man sich was Kleines schreiben. Also irgendeine Formelkombi mit der man die Länge des Wortes rausbekommt, die Buchstaben von hinten nach vorne wieder zusammensetzt und am besten alles in Bezug zur aktuellen Zelle also ne klene Schleife drehen. Bäng! Wirft es garantiert ein einen Fehler bei Excel weil Selbstbezug (Iterationsproblem, Zirkelbezug etc…ihr wisst schon). Was man bei einer Standardsuche findet sind dann schöne VB-Scripts, aber es soll auch anders gehen.

Excel Vorbereitung

Damit es auch mit den Zirkelbezug klappt und man eine Schleife hinbekommt muss man Excel etwas vorbereiten. Also

  1. Iterationswert hochsetzen
    Macht man über:  Datei > Optionen > Formeln > Berechnungsoptionen > Iterative Berechnung aktivieren: Hacken setzen
  2. Einen Zähler basteln den man nutzen kann damit man das schöne n+1 von einer Schleife hinbekommt:
    Eine Zelle nehmen diese direkt benennen damit darauf einfach referenzieren kann > Zelle anklicken > Rechtsklick > Namen definiere… > Namen eingeben
  3. In selbe Zelle folgendes schreiben =WENN(Zähler=100;1;Zähler+1)

Iterationswert hochsetzenNamen für Zelle vergebenZelle benennenExcel rückwärts schreiben

Zwischendurch mal abspeichern!
Hat man Worte mit mehr als 100 Zeichen dann die 100 hochsetzen.

Ich werde nicht die Formel erklären, wenn Jemand Interesse hat dies zu verstehen, wird er dies sicherlich nachvollziehen können oder muss sich anderweitig belesen.

Formel zusammen stellen

jetzt wird es interessant. Die Formel zusammenstellen.
Ich gehe davon aus dass der Text den ich umschreiben will in Zelle A1 befindet und die Formel eine Zelle daneben (B1)

  1. =WENN(Zähler>LÄNGE(A1);B1;WENN(Zähler=1;LINKS(A1);TEIL(A1;Zähler;1)&B1))

das wars.

Excel rückwärts schreiben

Werte übernehmen

Will man jetzt die Werte irgendwohin übernehme, empfehle ich eine csv bzw. txt rauszulassen und dann mit den Werte einfach so arbeiten, denn sonst hat man mit Copy n Paste aus Excel heraus nicht den erwünschten erfolgt. Einfach gehts auch aus dem Excel ein HTML machen zu lassen und dann aus dem Browser heraus Copy n Paste.

Viel Erfolg!

One Response to Excel Text rückwärts schreiben

  1. Hans says:

    Hallo,

    auf der Suche nach genau der Funktion ist mir gerade ein anderer Lösungsansatz eingefallen, aber danke für die Inspiration 😉

    =TEIL(A1;5;1)&TEIL(A1;4;1)&TEIL(A1;3;1)&TEIL(A1;2;1)&TEIL(A1;1;1)

    gibt 5 Stellen der Zelle A1 rückwärts zurück, kann man beliebig verlängern falls mehr (oder weniger) als 5 Zeichen in A1 vorhanden sind. Ist nicht ganz so elegant, dafür funktionierts ohne änderungen in den Einstellungen.

    MfG, Hans

Schreibe einen Kommentar zu Hans Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.